כששדרגתי את הבלוג מוורדפרס 2.1 שתורגם והותאם לעברית ע"י חנית (אח"י דקר) לוורדפרס 2.5 שתורגם והותאם לעברית ע"י רן יניב הרשטיין, נתקלתי בשתי בעיות שכמעט וגרמו לי לחזור לגירסה הישנה. למזלי, אחרי יומיים של שאלות וחיפושים בגוגל, מצאתי את התשובה במקום לא צפוי.

בעת השדרוג נתקלתי בבעיות הבאות:
1. כל הטקסט בבלוג הפך לג'יבריש. ואני לא מדבר על ג'יבריש שאפשר לפתור בהחלפת קידוד בדפדפן, אלא על כזה שנשאר ולא משנה באיזה קידוד נמצאים.
2. בראש הבלוג הופיעו לי שורות השגיאה הבאות:

Warning: array_keys() [function.array-keys]: The first argument should
be an array in /home/pega9510/domains/kotvim.co.il/public_html/copy/wp-
includes/widgets.php on line 654

Warning: Invalid argument supplied for foreach() in /home/pega9510/
domains/kotvim.co.il/public_html/copy/wp-includes/widgets.php on line
654

Warning: array_keys() [function.array-keys]: The first argument should
be an array in /home/pega9510/domains/kotvim.co.il/public_html/copy/wp-
includes/widgets.php on line 1307

Warning: Invalid argument supplied for foreach() in /home/pega9510/
domains/kotvim.co.il/public_html/copy/wp-includes/widgets.php on line
1307

אני לא אדכא אתכם בסיפורים על אותם יומיים ארורים של חיפושים ושאלות, אבל אני כן רוצה לציין שמזל שנתקלתי בבעיה מספר 1, אחרת לעולם לא הייתי מצליח לפתור את בעיה מספר 2.

הפתרון:
הפתרון הוא לגשת לקובץ wp-config.php ולמחוק בו שורה אחת (שורה מס' 7 אם אני זוכר נכון) שכתוב בה:

define(’DB_CHARSET’, ‘utf8′);

זה פעל ושתי הבעיות נפתרו יחדיו. אני מקווה שזה עוזר למי שנתקל בבעיות דומות 🙂

נ.ב.
מומלץ לבצע את מחיקת השורה לפני שדרוג מסד הנתונים.

תגיות: , , ,

2 תגובות

|
  • חנית says:

    בצורה מזעזעת במיוחד, מסתבר שהקובץ היחיד שלא צריך לשדרג בוורדפרס הוא wp-config.php יש ברשת לא מעט מאמרים על הצרות שהעסק הזה גורם.

  • יש שם כל מיני Fatal Errors החל מ widgets.php וכלה בinfo.php
    מה ששמתי לב שרוב המתלוננים הם כאלה שהבלוג שלהם הוא בשפה שאינה אנגלית.

|

כתיבת תגובה

האימייל לא יוצג באתר. שדות החובה מסומנים *